Поиск по штрихкоду в 1С

Поиск элементов справочника по коду

У справочников в 1С есть встроенные функции для поиска в них элементов, к ним относится НайтиПоКоду, НайтиПоНаименованию и НайтиПоРеквизиту;

В данном случае рассмотрим поиск по коду. Можно использовать когда необходимо получить предопределенный элемент.

Синтаксис:

Справочники.<НазваниеСправочника>.НайтиПоКоду(<Код>, <ПоискПоПолномуКоду>, <Родитель>, <Владелец>)

Параметры:

НазваниеСправочника — наименование справочника, к примеру Сотрудники.

Код — если код является строкой то задается в кавычках.

ПоискПоПолномуКоду — По умолчанию установлен в значении Ложь. Но если установить в истину то поиск будет вестись по полному коду элемента. Полный код состоит из всех кодов родителей(уровней) разделены «/». Пример: «00001/0002/0008″. (необязательный)

Родитель — Ссылка на родителя. Поиск будет вестись только по тем элементам где указан данный родитель. (необязательный)

Владелец — Ссылка на элемент владельца справочника, указанного на закладке Владельцы. (необязательный)

Результат:

Если элемент не найден возвращается ПустаяСсылка, иначе ссылка на элемент.

Если существует несколько элементов, возвращается только 1.

Если код отсутствует в справочнике, т.е. установлена длина 0, то возвращается Неопределено.

Поиск документов по штрихкоду в 1С 8

Рассмотрим подключение подсистемы штрихкодирования документов на примере подключения такого механизма в конфигурации 1С 8.2 и 8.3 Управление торговлей.

Зачем нужно штрихкодирование документов в 1С?

Штрихкодирование документов может понадобится для наведения порядка в бумажном документообороте — любому бумажному документу за считанные секунды можно найти электронный аналог в системе. Например, очень удобно когда клиенты приходят в офис с уже распечатанным заказом, в котором есть штрихкод — в этом случае обслуживание клиента занимает существенно меньше времени.

Настройка штрихкодирования документов 1С

Первый шаг к настройке штрихкодирования — создание штрихкода, хранение его в базе данных и распечатка на бумажном носителе.

Генерация штрихкода и сохранение его в 1С

Для хранения штрихкода создадим у документа новый реквизит — назовём его «штрихкод».
С генерацией нового штрихкода — немного труднее. Необходимо воспользоватся процедурой РаботаСТорговымОборудованием.СформироватьШтрихКод() из конфигурации управление торговлей, и сформировать его перед записью нового документа:

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения) ….. Если ЭтоНовый() Тогда Штрихкод = РаботаСТорговымОборудованием.СформироватьШтрихКод(); КонецЕсли; ….. КонецПроцедуры;

Распечатка штрихкода на печатной форме описана в отдельной статье — вывод на печатную форму штрихкода.
С установкой, хранением и распечаткой документов мы разобрались. Перейдем к другому этапу — поиск документов по штрихкоду.

Настройка поиска документа в 1С по штрихкоду

Рассмотрим поиск документа по штрихкоду из формы списка документа «Заказ покупателю».
Первым делом необходимо скопировать из других форм (например форма списка номенклатуры), отвечающие за работу с внешним оборудованием — сканером штрихкода. Вот процедуры, которые необходимо поместить в форму списка:

Процедура ВнешнееСобытие(Источник, Событие, Данные) ПолучитьСерверТО().ОбработатьВнешнееСобытие(Источник, Событие, Данные, ЭтаФорма); КонецПроцедуры Функция ПоддерживаетсяВидТО(Вид) Экспорт Результат = Ложь; Если Вид = Перечисления.ВидыТорговогоОборудования.СканерШтрихКода Тогда Результат = Истина; КонецЕсли; Возврат Результат; КонецФункции // ПоддерживаетсяВидТО() Функция СШКНоменклатура(Номенклатура, Характеристика, Серия, Качество, Единица, Количество, СШК) Экспорт Результат = Истина; Возврат Результат; КонецФункции // СШКНоменклатура() Функция СШКСерийныйНомер(Номер, СШК) Экспорт Возврат Истина; КонецФункции // СШКСерийныйНомер() Функция СШКИнформационнаяКарта(Карта, СШК) Экспорт Результат = Истина; Возврат Результат; КонецФункции // СШКИнформационнаяКарта() Функция СШКНеизвестныйКод(Штрихкод, ТипКода, СШК) Экспорт НайтиЗаказПоШтрихкоду(Штрихкод); Возврат Истина; КонецФункции // СШКНеизвестныйКод() Процедура СШКОшибка(Ошибка, Штрихкод, ТипШК, СШК) Экспорт Текст = ПолучитьСерверТО().ПолучитьТекстОшибкиСШКТО(Ошибка, Штрихкод, ТипШК); Предупреждение(Текст); КонецПроцедуры // СШКОшибка()
Обратите внимание на процедуру СШКНеизвестныйКод, если стандартные механизмы не смогли найти номенклатуру — они вернут нас в функцию «СШКНеизвестныйКод» где мы его и обработаем.
Опишем процедуру НайтиЗаказПоШтрихкоду, с помощью которой мы найдем нужный документ по штрихкоду и откроем его форму:
Процедура НайтиЗаказПоШтрихкоду(ТекШтрихкод) Запрос = Новый Запрос; Запрос.Текст = «ВЫБРАТЬ | ЗаказПокупателя.Ссылка |ИЗ | Документ.ЗаказПокупателя КАК ЗаказПокупателя |ГДЕ | ЗаказПокупателя.Штрихкод= &amp;Штрихкод»; Запрос.УстановитьПараметр(«Штрихкод», ТекШтрихкод); Результат = Запрос.Выполнить(); Если Результат.Пустой() Тогда Сообщить(«Заказ с штрихкодом » + ТекШтрихкод + » не найден»); Возврат; Иначе Выборка = Результат.Выбрать(); Выборка.Следующий(); СсылкаНаДокумент = Выборка.Ссылка; СсылкаНаДокумент.ПолучитьФорму().Открыть(); КонецЕсли; КонецПроцедуры
При выполнении данной процедуры будет происходить поиск нужного заказа по штрихкоду. Если заказ найден по штрихкоду — то система откроет заказ, не найден — сообщит об этом.

Штриходирование товаров в 1C:Предприятие Документооборот

1. Штрихкодирование документов

2. Вывод штрихкода в 1С 8.3 по шаблонам документа

3. Прочие преимущества штрихкодирования в 1С

4. Поиск по штрихкоду

5. Компонента печати штрихкода на документе

6. Подключение сканера штрихкодов для 1С

Штрихкодирование товаров — это технология нанесения графической информации (черных и белых полос либо других фигур) на поверхность, тем самым предоставляя возможность техническими средствами считывать «код». На сегодняшний день, самым популярным штриховым кодом является штрихкод EAN-13, представляющий собой одномерный тринадцатизначный код.

Система штрихкодирования предназначена для того, чтобы максимально ускорить и упростить процесс поиска файлов и документов в системе. Ведь штрихкод можно присвоить каждому документу и файлу в программе.

Штрихкодирование в 1С выполняется при помощи программного кода системы, а также специализированной компоненты (работает под ОС Windows и Linux), которая выполняет визуализацию штрихкода в изображение в форматах bmp, gif, jpeg, jpg, png, tiff, tif, wmf, emf, pdf.

1. Штрихкодирование документов

Для включения возможности использования штрихкодов, необходимо установить флаг: Настройка и администрирование → Настройка программы → Делопроизводство → Штрихкодирование документов.

После включения штрихкодирования в 1С появляется возможность настроить сканер, в том числе указать ⅭOM-порт, скорость и другие параметры.

В системе документооборота СЭД предусмотрены несколько вариантов организации штрихкодирования, каждый из которых будет описан подробно.

Совершенно необязательно печатать документ из «1С:Документооборота ПРОФ». Документ уже может быть у вас на руках, а распечатывать его повторно — это трата бумаги и времени. Более того, документ может быть уже подписан. Тогда его повторная распечатка невозможна. Для этого необходимо выбрать в меню документа «Печать» пункт «Регистрационный штамп» или «штрихкод на наклейке», или «штрихкод на странице».

Рассмотрим главные отличия пунктов меню «Печать»:

1. Пункт «Регистрационный штамп». В данном способе вывода изображения штрихкода дополнительно выводится информация о регистрационном номере и дате регистрации документа (данные с закладки «Регистрация» документа).

При изменении настроек область предпросмотра сразу показывает, как данные штрихкода будет вставлены в документ. Возможны два варианта:

■ с отображением цифр;

■ без отображения цифр.

Чтобы печатать цифры в нижней части штрихкода, необходимо установить флажок «Вставлять цифры в штрихкод». По умолчанию флажок снят и цифры печататься не будут.

Если установить флажок «Больше не показывать, сразу печатать», то выбранные настройки будут использоваться в дальнейшем автоматически.

Изображение штрихкода помещается в файл с параметром обтекания «Над текстом». При этом создается новая версия файла с комментарием Вставка штрихкода.

2. Пункт «Штрихкод на наклейке». При выводе на печать наклейки на страницу будет выведен только штрихкод. Выбрать место расположения штрихкода невозможно, так как оно не имеет значения (наклейка размещается на листе с данными вручную).

3. Пункт «Штрихкод на странице». Можно напечатать штрихкод на лист уже подписанного документа. Для того чтобы не испортить оригинал, выполняйте эту операцию только в случае полной уверенности, что вы предусмотрели все сопутствующие моменты (положение листа, ориентация листа, настройка размещения штрихкода и т. д.). Доступно из меню Печать командной панели карточки документа.

Все вышеизложенные варианты разрешают печатать штрихкод на любом бумажном носителе.

2. Вывод штрихкода в 1С 8.3 по шаблонам документа

В программе предусмотрена возможность автоматической вставки штрихкодов в 1С 8.3 в файлы, создаваемые из шаблонов.

Автоматически вставляется штрихкод в файл:

■ если файл был создан из шаблона;

■ если в шаблоне файла присутствует строка «<<ВставитьИзображениеШтрихкода>>». В этом случае изображение штрихкода заменяет собой эту строку.

3. Прочие преимущества штрихкодирования в 1С

Система документооборота СЭД также дает возможность присваивать штрихкод, который был сформирован в других системах. Они могут быть получены с документами из других программ, используемых контрагентами.

К примеру, может сложиться такая ситуация: организация получила документ, на котором уже есть изображение штрихкода.

Чтобы иметь возможность найти документ по этому штрихкоду, можно нанести сторонний штрихкод, при помощи меню «Еще» пункт «Штрихкоды — Добавить штрихкод».

После присвоения документу стороннего штрихкода, пользователь сможет начать поиск по штрихкоду.

На одном документе может быть напечатано любое количество сторонних штрихкодов.

Сторонние штрихкоды используют только для поиска документов и файлов, они не участвуют при печати и выгрузке изображения штрихкода на диск.

Если к копируемому документу прикреплен файл, в который автозаполнением был вставлен штрихкод, то при записи копии документа штрихкод в файле будет автоматически перезаполнен новым значением.

В файлы некоторых форматов автоматическая и ручная вставка штрихкода средствами системы невозможна. Для этого в группе команд Штрихкоды (меню Еще списков и карточек документов и файлов) предусмотрена команда Сохранить штрихкод.

Команда открывает стандартное окно операционной системы для указания пути сохранения изображения штрихкода. Штрихкод сохраняется на локальный диск в формате JPEG.

4. Поиск по штрихкоду

Поиск по штрихкоду возможен как в ручном, так и в автоматическом режиме.

Для ручного поиска необходимо использовать сочетание клавиш Ctrl + Shift + I. После этого откроется окно для ввода кода.

В системе может быть несколько одинаковых штрихкодов по документам. Пользователю будет предложен список всех документов на выбор. Одинаковые штрихкоды могут отображаться в системе, если документы были получены с таким же кодом от разных поставщиков.

5. Компонента печати штрихкода на документе

В программе 1С:Предприятие Документооборот предусмотрена компонента печати штрихкода на обычном листе с помощью обычного принтера. Для этого необходимо:

■ из карточки документа выполнить команду Штрихкод на странице, расположенную в группе Печать панели действий;

■ из списка документов выполнить команду Печать штрихкода на странице, расположенную в меню Еще – Штрихкоды.

Перед печатью будет предложено выбрать положение штрихкода на странице и принтер, на котором необходимо выполнить печать страницы.

Для отображения окна выбора положения штрихкода на закладке Штрихкодирование в персональных настройках программы нужно включить следующие настройки:

■ Открыть настройки при штрихкодировании – для выбора расположения штрихкода на странице во время выполнения операций Вставить штрихкод и Печать регистрационного штампа;

■ Положение штрихкода – для установки положения штрихкода по умолчанию.

6. Подключение сканера штрихкодов для 1С

Сканер штрихкодов для 1С — важнейший элемент системы, использующей штрихкодирование. Без него не будет возможности в полной мере реализовать все плюсы штрихкодирования. Для того чтобы начать работать со сканером, необходимо выполнить настройку: Персональные настройки → Штрихкодирование и нажать кнопку Подключение сканера штрихкодов.

После всего этого выбираем одну из настроек сканера.

В случае если в системе не заданы настройки, их необходимо будет создать. Для этого нужно заполнить поля, указанные на рисунке:

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *